Payment / Billing Vendor Down
Incident Report for No-IP
Resolved
We have worked with our 3rd party billing and payment vendor to resolve the issues causing errors loading my.noip.com and processing payments.

All systems are operational.
Posted May 23, 2019 - 06:24 PDT
Update
We have worked with our 3rd party billing and payment vendor to resolve the issues causing errors loading my.noip.com and processing payments.

All systems are operational.
Posted May 23, 2019 - 06:23 PDT
Update
Our 3rd party billing and payment processing vendor is currently down. This is causing multiple errors with purchases, payment processing and loading my.noip.com. We are working with our 3rd party vendor to resolve this as soon as possible.
Posted May 23, 2019 - 05:45 PDT
Identified
Our 3rd party billing and payment processing vendor is currently down. This is causing multiple errors with purchases, payment processing and loading my.noip.com. We are working with our 3rd party vendor to resolve this as soon as possible.
Posted May 23, 2019 - 05:45 PDT
This incident affected: Account Management (my.noip.com) and Payment Processing.