Degraded phone support: Zendesk Outage
Incident Report for No-IP
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 14:55 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2024 - 10:46 PDT
Investigating
Our 3rd party phone support provider Zendesk is currently experiencing performance issues resulting in no sound and dropped calls for phone support. For current incident information visit status.zendesk.com
Posted Apr 22, 2024 - 08:48 PDT
This incident affected: Support (noip.com/support).