Delayed DNS Updates
Incident Report for No-IP
Resolved
We've located the issue and able to resolve it. At this time all delayed DNS updates have been processed and we're seeing all new updates being processed in a timely manner.
Posted Aug 15, 2019 - 11:08 PDT
Investigating
We're looking into an issue that is causing DNS updates to be delayed. Any delayed update is queued and will be processed in the order received. DNS is still resolving for all domains.
Posted Aug 15, 2019 - 10:43 PDT
This incident affected: Free Dynamic DNS, Enhanced Dynamic DNS, and Plus Managed DNS.