Intermittent Webmail and IMAP/POP3 Connection
Incident Report for No-IP
Resolved
POP3/IMAP Managed Mail is fully functional. We're continuing to monitor for any further issues.
Posted May 29, 2020 - 13:41 PDT
Investigating
Our third party mail provider has reported an issue with POP3/IMAP Mail which is causing intermittent login for Webmail and mail clients.
Posted May 29, 2020 - 11:30 PDT
This incident affected: POP3 / IMAP Email.