CenturyLink outage affecting No-IP Integrations
Incident Report for No-IP
Resolved
The Century Link outage that has caused some integrated services to be unavailable has now been resolved. Over the last half hour traffic appears to have been restored to normal levels.

All systems are operational at this time.
Posted Aug 30, 2020 - 08:37 PDT
Identified
We have identified the issue causing errors with Zuora and our payment gateway: PayPal. CenturyLink, a global internet provider is currently experiencing an outage that is affecting some No-IP integrations with 3rd party vendors. Other services impacted are intermittent failures loading https://www.noip.com/ticket for No-IP support ticket requests.
Posted Aug 30, 2020 - 07:13 PDT
Investigating
Our third party billing and payment processing vendor, Zuora is currently experiencing issues connecting with PayPal for payment processing. We are currently investigating the full impact of this incident. For more information, view the Zuora incident here: https://trust.zuora.com/incidents/zx8mt2rc4f15
Posted Aug 30, 2020 - 06:40 PDT
This incident affected: Payment Processing and Support (noip.com/support).