Website Unavailable
Incident Report for No-IP
Resolved
This incident has been resolved.
Posted Sep 09, 2020 - 12:09 PDT
Monitoring
Our website is now stable. We will be monitoring the issue closely to prevent any further down time.
Posted Sep 09, 2020 - 09:22 PDT
Identified
We have identified the issue and a fix is being implemented. DNS and Dynamic updates are not affected, the impact is limited to the website.
Posted Sep 09, 2020 - 09:13 PDT
Investigating
Our website is currently unavailable. We're investigating the cause and working to rectify the issue as quickly as possible.
Posted Sep 09, 2020 - 08:59 PDT
This incident affected: Website, Account Management (my.noip.com), and Payment Processing.