Delays updating DNS records for some Free Dynamic DNS Domains
Incident Report for No-IP
Resolved
We have resolved the issue causing delays processing DNS updates for Free and Enhanced domains. All systems are operational at this time.
Posted Jul 17, 2019 - 11:49 PDT
Identified
We are currently investigating reports of delaying processing DNS updates for free Dynamic DNS domains. We will provide another update one we have further information.
Posted Jul 17, 2019 - 10:24 PDT
This incident affected: Free Dynamic DNS.