Delays processing DNS Updates
Incident Report for No-IP
Resolved
All DNS updates that were queued earlier today have successfully been completed. We're confident we've resolved the issue and will continue to monitor closely.
Posted May 11, 2019 - 20:48 PDT
Identified
We have identified the issue causing delays processing updates to DNS records. Our queues are working through a backlog of DNS updates and are processing updates to DNS records in the order received. Updates to DNS records will be delayed. We will continue to monitor the situation and provide an update once performance reaches normal levels.
Posted May 11, 2019 - 15:35 PDT
Update
Updates to DNS maybe delayed by several minutes.
Posted May 11, 2019 - 14:44 PDT
Investigating
We are currently experiencing issues with our checkout process. Please standby while we work diligently to fix this. Updates to DNS maybe delayed by several minutes.
Posted May 11, 2019 - 14:36 PDT
This incident affected: Free Dynamic DNS, Enhanced Dynamic DNS, Plus Managed DNS, and Payment Processing.