Webmail login issues
Incident Report for No-IP
Resolved
All affected services (users) have been corrected and are now online. Our partner's engineering team continues to work on ensuring the root cause is addressed and that preventative measures are in place for the future.
Posted Oct 13, 2020 - 18:01 PDT
Investigating
Our third party provider is currently investigating an issue affecting Webmail for customers . Users may experience the web page loading slowly or not at all. We will update as soon as we know more.
Posted Oct 13, 2020 - 11:44 PDT
This incident affected: POP3 / IMAP Email.