Delays sending and receiving email on Pop3 and Mail Forwarding Products
Incident Report for No-IP
Resolved
The issue has been resolved and we will continue to monitor it.

https://www.opensrsstatus.com/incidents/cp2m02hb11xq
Posted Aug 08, 2019 - 08:42 PDT
Monitoring
Our 3rd party mail provider is performing emergency maintenance on hardware that services No-IP POP3 and Mail Forwarding products. We are continuing to monitor this issue and will provide updates as the become available.

Real time updates are available at: https://www.opensrsstatus.com/incidents/cp2m02hb11xq
Posted Aug 07, 2019 - 10:29 PDT
This incident affected: POP3 / IMAP Email and Mail Forwarding.