Delays Validating TrustCor SSL Certificates
Incident Report for No-IP
Resolved
The issue causing validation delays and API failures with TrustCor SSLs have been resolved. All systems are operational.
Posted May 07, 2021 - 12:51 PDT
Identified
We have confirmed with our partner, TrustCor that a service outage affected their infrastructure causing delays validating certificates or failed API requests to create an SSL certificate. We are working to resolve the affected SSL requests and will provide another update shortly.
Posted May 07, 2021 - 11:44 PDT
Investigating
We are currently investigating reports of delays validating some TrustCor SSL certificates. We are working both internally and with our partner TrustCor to identify the issue.
Posted May 07, 2021 - 09:58 PDT
This incident affected: SSL Certificates.