Delays sending email through the Alternate Port SMTP product
Incident Report for No-IP
Resolved
The issues causing delays sending email through the Alternate Port SMTP product have been resolved.

All systems are operational at this time.
Posted Jul 24, 2019 - 10:48 PDT
Investigating
We are currently investigating reports of delays sending email through the Alternate Port SMTP product.
Posted Jul 24, 2019 - 09:14 PDT
This incident affected: Alternate-port SMTP.