Email login and access issues
Incident Report for No-IP
Resolved
We have resolved the issue with our Third Party Vendor. All mail services are now fully operational.
Posted Aug 27, 2020 - 13:45 PDT
Update
We are continuing to investigate this issue.
Posted Aug 27, 2020 - 12:07 PDT
Investigating
One of No-IP's third party vendors is currently experiencing an issue where IMAP/POP/Webmail users may notice they are unable to log in or access their mailbox. We are working with this vendor and will update as soon as we learn more.
Posted Aug 27, 2020 - 12:07 PDT
This incident affected: POP3 / IMAP Email, Mail Forwarding, Alternate-port SMTP, and Backup MX / Mail Reflector.