Partial Outage with No-IP's 3rd Party Payment Processor
Incident Report for No-IP
Resolved
This incident has been resolved.
Posted Mar 09, 2021 - 16:16 PST
Monitoring
We are no longer seeing 500 errors. We will continue to monitor the incident closely.
Posted Mar 09, 2021 - 15:27 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 09, 2021 - 15:09 PST
Investigating
No-IP's 3rd party billing and payment processor, PayPal is currently experiencing a partial outage resulting in intermittent 500 errors on No-IP's payment processing pages.

No-IP is closely monitoring the situation and we apologize for any inconvenience this has caused.
Posted Mar 09, 2021 - 14:53 PST
This incident affected: Payment Processing.