Issues with 3rd party payment and billing platform that is causing errors with No-IP payment processing.
Incident Report for No-IP
Resolved
Our 3rd party billing and payment vendor was able to resolve the issue on their end and we're now seeing successful API calls.
Posted Oct 01, 2019 - 15:13 PDT
Update
We are continuing to work with our 3rd party billing and payment vendor to resolve this issue. For up to date information, please see https://trust.zuora.com/incidents/60ds4l8br0y0
Posted Oct 01, 2019 - 13:16 PDT
Identified
We have identified the issue causing API failures with our 3rd party billing and payment processor. We are working with them to resolve this issue.
Posted Oct 01, 2019 - 11:07 PDT
Investigating
We are currently investigating an issue with our 3rd party billing platform that is causing errors with No-IP payment processing and pages that contain billing information. We have notified the vendor and are waiting on a response. We will provide an update when we additional information.
Posted Oct 01, 2019 - 10:05 PDT
This incident affected: Account Management (my.noip.com) and Payment Processing.