Email management connection issues and delayed mail
Incident Report for No-IP
Resolved
All connectivity has been restored.
Posted Sep 14, 2020 - 13:59 PDT
Update
In the cases where mail was delayed, mail is now being delivered promptly. Managing Pop3 Email and Forwarding accounts on www.noip.com are still affected.
Posted Sep 12, 2020 - 22:32 PDT
Identified
We're having connection issues with our email partner. Management of Pop3 Email and Forwarding accounts are affected. Delivery of email may be delayed if the MX records of the Managed Mail domain are mail1.no-ip.com. Please use mx.noip.com as describe in our knowledgebase article: https://www.noip.com/support/knowledgebase/i-have-no-ip-pop3imap-how-do-i-retrieve-my-email-using-my-email-client/.
Posted Sep 12, 2020 - 14:35 PDT
This incident affected: POP3 / IMAP Email and Mail Forwarding.