Issues loading noip.com
Incident Report for No-IP
Resolved
The measures put in place to mitigate impacts to our networks from abusive IPs have resolved the issues loading noip.com. All systems are operational.
Posted Jul 15, 2021 - 11:24 PDT
Monitoring
We have put measures in place to mitigate impacts to our networks from abusive IPs and the impact to the website appears to be resolved. We will continue to monitor this over the next few hours.
Posted Jul 15, 2021 - 10:48 PDT
Investigating
We are currently investigating reports of issues loading noip.com. Initial research is pointing to a denial of service attack that is overwhelming our network. DNS services are not affected. We will continue to investigate and work to mitigate this attack.
Posted Jul 15, 2021 - 09:02 PDT
This incident affected: Website and Account Management (my.noip.com).