DNS Resolution Interruption

Incident Report for No-IP

Resolved

We have resolved the DNS resolution disruption and are working on additional safeguards to prevent similar occurrences in the future.

We sincerely apologize for any disruption this may have caused and appreciate your patience as we worked to resolve it.
Posted Apr 17, 2025 - 22:31 PDT

Monitoring

Earlier today, we experienced a brief interruption in DNS resolution due to an unexpected issue following a configuration update. The update caused our name servers to temporarily become unresponsive, leading to a roughly 10-minute window where DNS queries may have failed to resolve. DNS cashing may have caused longer resolution failures in some cases.

Our engineering team quickly identified the issue and restored full functionality.
Posted Apr 17, 2025 - 22:30 PDT