Alternate port SMTP delivery problems

Incident Report for No-IP

Resolved

The issue affecting Alternate Port SMTP has been resolved the queue backlog as normalized. All systems are operational.
Posted Aug 31, 2026 - 16:04 PDT

Monitoring

Connectivity has been restored. Alternate port SMTP mail that was delayed is now moving through the queue and being delivered. Expect queue delays for the next hour or so while the backlog processes. We will continue monitoring.
Posted Aug 31, 2026 - 13:09 PDT

Identified

We are seeing delivery problems on our alternate port SMTP service. The
cause is a routing problem affecting part of the network our mail servers
send from. Our team is working on a fix.

We have a temporary reroute in place to keep traffic moving while we sort
out the underlying problem. One known limitation: mail sent to a group
address or through a forward may still bounce, depending on how the
receiving side is configured.

We will post an update here as soon as we know more.
Posted Aug 31, 2026 - 12:23 PDT
This incident affected: Alternate-port SMTP.