We have resolved the issue causing Free Dynamic DNS hostnames to timeout. Over the last several days No-IP has been upgrading our Free Dynamic DNS infrastructure. During this process, some of the new servers fell behind processing Dynamic IP updates and caused Free Dynamic DNS hostnames to point to old IP addresses.
Posted Apr 17, 2018 - 10:32 PDT
Identified
We have identified and resolved the issue causing slow propagation for Free Dynamic DNS updates. Dynamic updates are quickly recovering. We will close this incident once we see a full recovery.
Posted Apr 17, 2018 - 10:00 PDT
Investigating
We are investigating reports of slow DNS propagation for dynamic IP updates on our Free Dynamic DNS service. We will provide an update as soon as we have more information.