Email login and access issues
Incident Report for No-IP
Resolved
The issue has now been resolved.
Posted Aug 14, 2022 - 07:57 PDT
Identified
One of No-IP's mail providers is reporting users are experiencing issues with login. They have identified the issues and are working to restore the failed services. We will update when we learn more
Posted Aug 13, 2022 - 16:48 PDT
This incident affected: POP3 / IMAP Email and Mail Forwarding.