Degradation of Hosted Email Services
Incident Report for No-IP
Resolved
The issue has been resolved and all services are fully operational.
Posted Oct 05, 2021 - 14:04 PDT
Investigating
Our third party partner has reported customers experiencing degradation in service of Hosted Email (Inbound/Outbound Mail, IMAP, POP3). They are currently investigating the issue. We will update as soon as we know more.
Posted Oct 05, 2021 - 13:46 PDT
This incident affected: POP3 / IMAP Email and Mail Forwarding.