Degraded Database Performance Affecting Dynupdate API and our Website
Incident Report for No-IP
Resolved
The issues affecting our database performance have been resolved and all systems are operational.
Posted Jan 26, 2022 - 10:38 PST
Monitoring
We are seeing improved database performance as a result of several mitigation measures implemented today. We will continue to monitor the situation and will provide another update shortly.
Posted Jan 25, 2022 - 16:23 PST
Identified
We are currently working to resolve the cause of degraded database performance affecting dynupdate API and our website, first identified on 1/24. Recent mitigation measures have improved database performance, but we are still seeing query failures. We will provide an update as soon as we have more information.
Posted Jan 25, 2022 - 09:51 PST
This incident affected: Website, Account Management (my.noip.com), and Dynamic Update API.