DNS update delays for Free and Enhanced DNS Services
Incident Report for No-IP
Resolved
This incident has been resolved.
Posted Jul 13, 2021 - 19:45 PDT
Update
Connectivity problems between locations caused some queues to become impacted. All updates have been handled and no further delays expected.
Posted Jul 13, 2021 - 19:45 PDT
Investigating
We are currently investigating reports of DNS update delays on our Free and Enhanced DNS services. Based on initial research, all updates have been received, however we are experiencing delays processing our update queue. We will provide an update as soon as we have more information.
Posted Jul 13, 2021 - 19:20 PDT
This incident affected: Free Dynamic DNS and Enhanced Dynamic DNS.