Issues reported with 3rd party transactional email provider
Incident Report for No-IP
Resolved
SendGrid is reporting they have resolved their issues impacting No-IP transactional email mail.

All systems are operational.
Posted Jul 13, 2021 - 21:17 PDT
Identified
SendGrid, our 3rd party transactional email provider is reporting authentication issues with their APIs. This affects outbound transactional email from No-IP such as account confirmation, password reset, system notices, billing notifications and other system emails. We will continue to monitor SendGrid updates for more information.
Posted Jul 13, 2021 - 21:02 PDT
This incident affected: No-IP Transactional Email.