Impacted Services for POP3 and IMAP Email Services
Incident Report for No-IP
Resolved
The issue preventing email users from logging into webmail has been identified and resolved.
Posted Mar 29, 2023 - 09:09 PDT
Investigating
No-IP's third party email provider is reporting an issue preventing some email customers from logging into Webmail. We will update as we learn more from our email provider
Posted Mar 29, 2023 - 08:54 PDT
Monitoring
No-IP's third party email provider has resolved the issue preventing customer from receiving emails and emails are starting to deliver. We are monitoring the situation and will update as we learn more
Posted Mar 27, 2023 - 16:45 PDT
Identified
Customers are experiencing degraded email services as a result of the email migration and maintenance activities. Customers may receive duplicate emails or may not be able to receive emails at this time. We are currently working with our third party email provider to get these issues resolved. We will provide an update when we learn more.
Posted Mar 26, 2023 - 11:59 PDT
Monitoring
Migration has been completed and customers should be experiencing a return to normal email operation. We will continue to monitor the situation.
Posted Mar 15, 2023 - 08:41 PDT
Investigating
No-IP's third party email provider is performing migration and maintenance services. As a result customers using our email services may experience duplicate emails, missing older emails, and possible delays in receiving emails. These issues are know and are being worked on. We will provide an update when we learn more.
Posted Mar 14, 2023 - 09:17 PDT
This incident affected: POP3 / IMAP Email.