Managed DNS – Delayed DNS Propagation Between Primary and Secondary Servers

Incident Report for No-IP

Resolved

DNS updates are now propagating to secondary servers in real time.

All systems are operating normally.
Posted Apr 23, 2026 - 20:09 PDT

Monitoring

We have identified the root cause of the issue and implemented a fix. DNS update delays are now beginning to decrease as changes propagate through the system.

We will continue to monitor performance closely and provide further updates as needed.
Posted Apr 23, 2026 - 19:57 PDT

Investigating

We are currently investigating an issue impacting Managed DNS zones where DNS updates are experiencing delays propagating from our primary DNS servers to our secondary DNS servers.

During this time, recent DNS changes may not be reflected immediately across all authoritative servers, which could result in inconsistent DNS resolution depending on the querying resolver.

Our engineering team is actively working to identify the root cause and restore normal propagation times. We will provide updates as more information becomes available.
Posted Apr 23, 2026 - 17:38 PDT
This incident affected: Plus Managed DNS.