Elevated Decline Rates For New Payment Methods
Incident Report for No-IP
Resolved
Our payment processor, Braintree has resolved the issue that caused all new Visa and Mastercard payment methods to fail verification. After their change was implemented we have seen successful transactions. This issue is now resolved
Posted Sep 18, 2024 - 12:47 PDT
Investigating
We are currently investing elevated decline rates for new payment methods. We have reached out to our payment processor and they are currently investigating the issue.
Posted Sep 17, 2024 - 08:36 PDT
This incident affected: Payment Processing.