Degraded Performance – Outbound API Integrations

Incident Report for No-IP

Resolved

This incident is resolved - all systems are operational.
Posted Mar 25, 2026 - 11:12 PDT

Monitoring

The issue impacting outbound API integrations has been resolved. All systems are now operating normally.

We will continue to monitor performance to ensure stability. Thank you for your patience while we worked to resolve this issue.
Posted Mar 25, 2026 - 07:57 PDT

Investigating

We are currently investigating an issue impacting outbound API integrations. Customers may experience delays or failures when interacting with external API-dependent services.

Our team is actively working to identify the root cause and will provide updates as more information becomes available.
Posted Mar 25, 2026 - 07:45 PDT
This incident affected: Domain Registration, POP3 / IMAP Email, Mail Forwarding, Alternate-port SMTP, Backup MX / Mail Reflector, SSL Certificates, and Payment Processing.