Elevated errors on the Dynamic DNS update endpoint

Incident Report for No-IP

Resolved

This incident has been resolved. The fix deployed for the elevated errors on our Dynamic DNS update endpoint (dynupdate.no-ip.com) has held, and update requests have returned to processing normally. We have confirmed full recovery and the endpoint is operating as expected.
Posted Aug 17, 2026 - 10:01 PDT

Monitoring

We have deployed a fix for the elevated errors on our Dynamic DNS update endpoint (dynupdate.no-ip.com) and are beginning to see recovery, with update requests processing normally again. We are continuing to monitor the endpoint closely to confirm full recovery.
Posted Aug 17, 2026 - 09:17 PDT

Investigating

We are investigating an issue affecting our Dynamic DNS update endpoint (dynupdate.no-ip.com). Some update requests are currently returning a 911 response, which may prevent affected hostnames from updating their IP address as expected.

Our team is actively looking into the cause and working to restore normal update processing as quickly as possible. We apologize for the inconvenience and appreciate your patience.

We will post further updates here as we learn more.
Posted Aug 17, 2026 - 08:14 PDT
This incident affected: Dynamic Update API.