Degraded phone and ticket support: Zendesk outage
Incident Report for No-IP
Resolved
Our 3rd party support provider, Zendesk has resolved the incident affecting No-IP phone and ticket support. We apologize for the inconvenience this may have caused. If your call was dropped when speaking with No-IP support, please give us a callback and we will be happy to help!
Posted Mar 28, 2022 - 09:50 PDT
Identified
Our 3rd party phone and ticket support provider Zendesk is currently experiencing performance issues resulting in dropped No-IP phone support calls and degraded ticket support. For current incident information visit status.zendesk.com
Posted Mar 28, 2022 - 08:53 PDT
This incident affected: Support (noip.com/support).