Impacted Services for POP3 and IMAP Email Services
Incident Report for No-IP
Resolved
Our third party email vendor has identified and resolved the issue. All POP3 and IMAP services have been restored.
Posted Mar 02, 2022 - 11:47 PST
Investigating
Our third party email vendor is experiencing an issue impacting POP3and IMAP email services. We are investigating and will provide an update as soon as we learn more. During this time POP3 and IMAP email services will be degraded. Users may not be able to log in or access email.
Posted Mar 02, 2022 - 11:07 PST
This incident affected: POP3 / IMAP Email.