Alternate-port SMTP, and mail1.no-ip.com unavailable

Incident Report for No-IP

Resolved

This incident has been resolved.
Posted Apr 12, 2022 - 20:45 PDT

Update

We are continuing to investigate this issue.
Posted Apr 12, 2022 - 20:22 PDT

Investigating

Configuration and IP propagation during our maintenance window took longer than expected. We are currently working to restore service as soon as the routes update.
Posted Apr 12, 2022 - 20:22 PDT
This incident affected: Alternate-port SMTP and Backup MX / Mail Reflector.